Algoritmi maxim/minim a 2, 3 numere

2 Dec

MAXIMUL  A 2  NUMERE : Se dau 2 numere: a, b, c. Se cere sa se afiseze cel mai mare dintre acestia.

Start

     Citeste a , b

     Daca a > b atunci max ← a

     Altfel max ← b

     Scrie max

Stop

 MINIMUL  A  3  NUMERE :

start

      citeste a, b , c

      daca a > b atunci min1 = b

      altfel min1 = a

      daca min1 > c atunci min = c

      altfel min = min1

      scrie min

stop

MAXIMUL   A  3  NUMERE :

start

citeste a, b, c

      daca a>b atunci max1 = a

      altfel max1 = b

      daca max1>c atunci max = max1

      altfel max = c

      scrie max

stop 

MINIMUL  A  2  NUMERE :

start

citeste a, b

     daca a<b atunci min = a

     altfel min = b

      scrie min

stop

About these ads

Lasă un răspuns

Completeaza detaliile de mai jos sau apasa click pe una din imagini pentru a te loga:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Schimbă )

Twitter picture

You are commenting using your Twitter account. Log Out / Schimbă )

Facebook photo

You are commenting using your Facebook account. Log Out / Schimbă )

Google+ photo

You are commenting using your Google+ account. Log Out / Schimbă )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

%d bloggers like this: