Ordonarea a 2, 3 numere

2 Dec

Se dau 2 numere naturale. Se cere sa se afiseze cele 2 numere in ordine crescatoare.

start

    citeste a, b

    daca a>b atunci scrie b, a

    altfel scrie a, b

stop

start

    citeste a, b

    daca a>b atunci aux  ← a

                                     a ← b

                                     b ← aux

    scrie a, b

stop

    Ordonarea a 3 numere:

start

    citeste a, b, c

    daca a <b atunci aux ← a

                                       a  ← b

                                       b ← aux

    daca a<c atunci aux ← a

                                     a ← c

                                     c ← a

    daca b<c atunci aux ← b

                                     b ← c

                                     c ← aux

    scrie a, b, c

stop

Lasă un răspuns

Completează mai jos detaliile despre tine sau dă clic pe un icon pentru autentificare:

Logo WordPress.com

Comentezi folosind contul tău WordPress.com. Dezautentificare / Schimbă )

Poză Twitter

Comentezi folosind contul tău Twitter. Dezautentificare / Schimbă )

Fotografie Facebook

Comentezi folosind contul tău Facebook. Dezautentificare / Schimbă )

Fotografie Google+

Comentezi folosind contul tău Google+. Dezautentificare / Schimbă )

Conectare la %s

%d blogeri au apreciat asta: