Top 10 filme 2010

13 Ian

 

  • Black Swan
  • Inception
  • The Tourist
  • Harry Potter and the Deathly Hallows: Part 1
  • Legend of the Guardians: The Owls of Ga'Hoole
  • Shutter Island
  Titlu film Nota
1. Black Swan (2010) 9.1
2. Inception – Inceputul (2010) 9
3. The Tourist – Turistul (2010) 8.7
4. Harry Potter and the Deathly Hallows: Part 1 – Harry Potter si Talismanele Mortii: Partea I (2010) 8.6
5. Legend of the Guardians: The Owls of Ga’Hoole – Legende din regatul bufnitelor (2010) 8.6
6. Shutter Island (2010) 8.6
7. How to Train Your Dragon – Cum sa-ti dresezi dragonul (2010) 8.5
8. Despicable Me – Sunt un mic ticalos (2010) 8.5
9. The Pacific (2010) 8.5
10. Alice in Wonderland – Alice în Tara Minunilor (2010) 8.4
18 Dec

                                                         Structura Repetitiva

1) Structura repetitiva cu numar necunoscut de pasi

– structura repetitiva – cu test initial

                                              – cu test final

2) Structura repetitiva cunumar cunoscut de pasi:

                            Structura repetitiva cu test initial      

  a) forma generala

cat timp conditie executa

instructiuni

        b) efect

  • se verifica conditia
  • daca conditia este adevarata atunci se executa instructiuni si se revine la verificarea conditiei
  • altfel se paraseste structura repetitiva

c) Observatii:

  • instructiunile se executa cat timp conditia este adevarata
  • instructiunile trebuie sa-i permita conditiei sa devina falsa (pentru ca algoritmul sa se termine)
  • este posibil ca instructiunile sa nu se execute niciodata (atunci cand conditia este falsa de la inceput)

Istoricul notiunii de algoritm

2 Dec

  Daca in matematica notiunea cea mai importanta este numarul , in informatica cea mai importanta notiune cu care se lucreaza este algoritmul .

Scurt istoric O prima carte de algoritmica este cunoscut inca din secolul VIII- IX, scris a de autorul persan Abu Jafar Mohammed ibn Musa al- Khowarizm si cunoscut in traducere latina ca Algorithmi de numero indorum, iar apoi ca Liber algorithm. Numele de algoritmi provine de la al Khowarizm ceea ce inseamna din orasul Khowarizm. Atat Al-Khowarizm cat si alti matematicieni din evul mediu intelegeau prin algoritm o regula pe baza caruia se efectuau calcule aritmetice. In secolul al XVI-lea algoritmii se foloseau la dublari, injumatatiri, inmultiri de numere. In secolul XIX Kronecker (in 1886) si Dedekind (in 1888) pun bazele teoriei functiilor recursive. Conceptul de recursivitate devine straans legat de cel de algoritm. De-abia in deceniile al treilea si al patrulea al secolului XX, teoria recursivitatii si a algoritmilor incepe sa se constituie ca atare prin lucrarile lui Skolem, Ackermann, Godel, Churck, Kleene, Turing, etc. Aparuta initial ca un instrument matematic, gaandirea algoritmica s-a transformat intr-o modalitate fundamentala de abordare a problemelor care nu au nimic de-a face cu matematica. O definitie a notiunii de algoritm este greu de dat. Exista diferite incercari de a defini algoritmii. Ceea ce da generalitate notiunii de algoritm este ca el poate opera nu numai cu numere. Exista algoritmi algebrici, algoritmi logici, algoritmi genetici, etc. Dar algoritmi pot intalniti in orice domeniu de activitate: algoritmul de a construi o casa, de a schimba roata la o masina, pana si o reteta culinara poate privita ca un algoritm. Universalitatea gaandirii algoritmice este rezultatul conexiunii dintre algoritmsi calculator. Un algoritm este reprezentat de o multime finita de reguli de calcul care indica succesiunea de operatii necesare rezolvarii unui tip de problema. Putem spune ca un algoritm este o metoda generala de rezolvare a unui tip de problema, metoda care se poate implementa pe calculator. In acest context un algoritm este esenta unei rutine. Un algoritm se caracterizeaza prin doua componente: domeniul algoritmului; descrierea propriu-zisa a algoritmului.

Ordonarea a 2, 3 numere

2 Dec

Se dau 2 numere naturale. Se cere sa se afiseze cele 2 numere in ordine crescatoare.

start

    citeste a, b

    daca a>b atunci scrie b, a

    altfel scrie a, b

stop

start

    citeste a, b

    daca a>b atunci aux  ← a

                                     a ← b

                                     b ← aux

    scrie a, b

stop

    Ordonarea a 3 numere:

start

    citeste a, b, c

    daca a <b atunci aux ← a

                                       a  ← b

                                       b ← aux

    daca a<c atunci aux ← a

                                     a ← c

                                     c ← a

    daca b<c atunci aux ← b

                                     b ← c

                                     c ← aux

    scrie a, b, c

stop

Algoritmi maxim/minim a 2, 3 numere

2 Dec

MAXIMUL  A 2  NUMERE : Se dau 2 numere: a, b, c. Se cere sa se afiseze cel mai mare dintre acestia.

Start

     Citeste a , b

     Daca a > b atunci max ← a

     Altfel max ← b

     Scrie max

Stop

 MINIMUL  A  3  NUMERE :

start

      citeste a, b , c

      daca a > b atunci min1 = b

      altfel min1 = a

      daca min1 > c atunci min = c

      altfel min = min1

      scrie min

stop

MAXIMUL   A  3  NUMERE :

start

citeste a, b, c

      daca a>b atunci max1 = a

      altfel max1 = b

      daca max1>c atunci max = max1

      altfel max = c

      scrie max

stop 

MINIMUL  A  2  NUMERE :

start

citeste a, b

     daca a<b atunci min = a

     altfel min = b

      scrie min

stop

Algoritmul de interschimbare

2 Dec

   

Se dau 2 numere. Se cere sa se interschimbe valorile celor 2 variabile.

aux a

a ← b

b ← aux

 

 

 

Alvin and the Chipmunks

26 Noi

    The group’s name changed from „The Chipmunks” to „Alvin & The Chipmunks” just like „Diana Ross & The Supremes”. Alvin, just like Diana Ross, was the lead singer.[3] The Chipmunks’ name change sparked rumors of a possible solo career for Alvin, but in 1983, the second animated television series for the group, produced by Ruby-Spears Productions, was released.

Titled simply Alvin and the Chipmunks, the outline of the show closely paralleled the original Alvin Show. A more sustained success than the original, the series lasted eight production seasons, until 1990. In the first season, the show introduced the Chipettes, three female versions of the Chipmunks — Brittany, Jeanette, and Eleanor, who each paralleled the original Chipmunks in personality (except Brittany was vainer than Alvin, Jeanette was smart like Simon, and Eleanor was fond of food like Theodore), with their own human guardian, the myopic Miss Beatrice Miller (who arrived for the 1986 season).